// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w{3})(\w+)?(\w{3})").unwrap();
let string = "Hmm. We’re having trouble finding that site.
Check that Firefox has permission to access the web (you might be connected but behind a firewall)
vamos fazer de conta que criamos um projeto de multipla escolha
codigo-cliente-no-cadastro-unico
cxp-microintegration-teste-sistema-conta
testando-abreviação-simples-com-expressões-regulares
Your account, a is not authorized to view this page. Make sure the URL is correct and your account has access.";
let substitution = "$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}