import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{2} \\d{3} \\d{3} \\d{3}\\b|\\b\\d{11}\\b|\\b\\d{2} \\d{6} \\d{3}\\b|\\b\\d{8} \\d{3}\\b|\\b\\d{2} \\d{4} \\d{5}\\b|\\b\\d{2} \\d{9}\\b";
final String string = "12 345 678 901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}