using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%\s*Parameter|(Parameter.*)";
string input = @"Parameter: A
%Parameter: B
% Parameter: C
Parameter: D %the best parameter";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}