import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|(\\d+)\\b(?<=\\b(?=\\|?\\1\\b).{1,999}?\\|\\d{1,9})";
final String string = "0612|0613|061|0612|0612\n"
+ "0211|0612|021|0212|0211|0211\n"
+ "0111|0111\n"
+ "0511|0512|0511|0511|0521|0512|0511\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}