use strict;
my $str = '0612|0613|061|0612|0612
0211|0612|021|0212|0211|0211
0111|0111
0511|0512|0511|0511|0521|0512|0511
';
my $regex = qr/\|(\d+)\b(?<=\b(?=\|?\1\b).{1,999}?\|\d{1,9})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";