package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+ \S+$`)
var str = `word word
word word word
word word word word
word
a a
a a a
b b
b b b
FOO BAR
a
b
c
d d
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}