import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(> \\[!anki]- .+(?:\\n(?!<!--).+)*)(?:\\n<!-- end of flashcard -->)?";
final String string = "> [!anki]- Title\n"
+ "> Answer\n\n"
+ "> [!anki]- Title\n"
+ "> Answer\n"
+ "<!-- end of flashcard -->\n\n"
+ "> [!anki]- Title\n"
+ "> Answer\n"
+ "> Another line\n"
+ "> Another line\n\n"
+ "> [!anki]- Title\n"
+ "> Answer\n"
+ "^7a6a36";
final String subst = "$1\\n<!-- end of flashcard -->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}