import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.[A-Za-z]+\\.\\d+";
final String string = "aaa/prt001.prt.1\n"
+ "aaa/prt001.prt.2\n"
+ "aaa/prt001.prt.3\n"
+ "aaa/prt001.prt.4\n"
+ "aaa/prt001.prt.5\n"
+ "aaa/prt001.prt.10\n"
+ "aaa/prt001.asm.1\n"
+ "aaa/prt001.asm.2\n"
+ "aaa/prt001.asm.3\n"
+ "aaa/prt001.txt.10\n"
+ "aaa/prt001.txt.20\n"
+ "aaa/prt001.txt.30\n"
+ "bbb/prt001.prt\n"
+ "bb/prt.001.prt\n"
+ "bb/prt.001.prt.1\n"
+ "bb/prt.001.1\n"
+ "bb/prt.ppp.prt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}