#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^\.+|(\.)\.+)"
Local $sString = "543.210.987.654.321" & @CRLF & _
"43.210.987.654.321" & @CRLF & _
"987.654...321" & @CRLF & _
"87.654...321" & @CRLF & _
"7.654...321" & @CRLF & _
"654....321" & @CRLF & _
"54....321" & @CRLF & _
"4....321" & @CRLF & _
"....321" & @CRLF & _
"21" & @CRLF & _
"1" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)