using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\.+|(\.)\.+)";
string substitution = @"$1";
string input = @"543.210.987.654.321
43.210.987.654.321
987.654...321
87.654...321
7.654...321
654....321
54....321
4....321
....321
21
1
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}