package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^\.+|(\.)\.+)`)
var str = `543.210.987.654.321
43.210.987.654.321
987.654...321
87.654...321
7.654...321
654....321
54....321
4....321
....321
21
1
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}