$re = '/https:\/\/stage.in.app.com\/usert\/[^\s,]+\b[\"\']/m';
$str = '[https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3">https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3</a]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);