const regex = /^\s*Processo\s*\d{7}\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*Processo\\s*\\d{7}\\-\\d{2}\\.\\d{4}\\.\\d\\.\\d{2}\\.\\d{4}\\,', 'gm')
const str = `PROCESSO :1000069-51.2019.8.26.0486
Processo 0000508-21.2015.8.26.0486
Processo 0010464-93.2018.8.26.0506/02
Processo 0022276-35.2018.8.26.0506/562
Nº 0000002-25.2019.8.26.9048
540.423 -
1.125.553 -
NPE 950.128
PEC 910.494
NPE 1.177.941
EXPEDIENTE AVULSO - NPE 1.089.733
EXECUÇÃO: 699.764
EXECUÇÃO: 1.101.909
CPPJ 12/2013 E 64/2013
1. EXECUÇÃO Nº 629.142
2. EXECUÇÃO Nº 1.013.657
PROTOCOLO Nº 543 FSBL 1800017858-9
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}