const regex = new RegExp('(^((\\*\\/)?([1-5]?[0-9])((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?((2[0-3]|1[0-9]|[0-9]))((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?([1-9]|[12][0-9]|3[01])((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?([1-9]|1[0-2])((\\,|\\-|\\/)\\d+)*|\\*)\\s((\\*\\/)?[0-6]((\\,|\\-|\\/)\\d+)*|\\*)$)|@(annually|yearly|monthly|weekly|daily|hourly|reboot)', 'gm')
const str = `# should pass:
12 1 1 * 1
0 1 1 * 1,2
0 1 1 * 1,2,3
0 1 * * 1/4
0 */2 * * *
0 9-17 * * *
0 * * * 2/4
* * * * *
* * * * *
0 4 * * 1-5
*/5 * * * *
37 1-23/2 * * *
0 0,12 1 */2 *
0 0 1,15 * 3
@weekly
0 5,17 * * *
5 0 * 8 *
0 22 * * 1-5
23 0-20/2 * * *
0 0,12 1 */2 *
# should not pass:
0 * * 0 1-4
0 0 0 12 *
*-* * * * *
* * *-1 * *
*1 * 1 * *
1* * 1 * *`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}