package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$`)
var str = `/some/path-to-fie/resource.zip
google.com/some/path-to-fie/resource.zip
https://google.com/some/path-to-fie/10000/3213/resource.ext
http://google.com/some/path-to-fie/resource.doc
://google.com/some/path-to-fie/resource.png
./some/path-to-fie/resource.zip
/resource.png
// You can show origina post on albertcolom.com/blog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}