$re = '/^((\/|\\\\|\/\/|https?:\\\\\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\\\[\]]+)+\.[a-z]+$/mi';
$str = '/some/path-to-fie/resource.zip
google.com/some/path-to-fie/resource.zip
https://google.com/some/path-to-fie/10000/3213/resource.ext
http://google.com/some/path-to-fie/resource.doc
://google.com/some/path-to-fie/resource.png
./some/path-to-fie/resource.zip
/resource.png
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);