// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\.)+[a-zA-Z]{2,}$").unwrap();
let string = "Exemple@mail.com
exemple@mail.fr
exEmPle.exemple@mail.to
exemple.exemple.exemple@mail.org
EXEMPLE.exemple.EXEmple@mail.de
exemple+test@Màil.com
_exemple@Mail.com
_exemple.test@Mail-test.com
_exemple+test@mail-test-café.co.uk
exe_mple.test+tag@mail.com
exe_mple.test@mail.subdomain.com
exe_mple+test@mail.com
exemple@good2go.com
NotValid@mail.c
NotValid@mail
Not@.valid
@not.valid
@notvalid
notvalid@
notvalid.com
notvalid@";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}