re = /^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$/m
str = '1a2b3cd2312321
12q32131231231f
32132131231231231231221
aa
12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw
12222a22333fw342434234234weqweqw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end