using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$";
string substitution = @"$1$2$3$4$5$6$7$8$9${10}";
string input = @" stuff before 18005551234567 stuff after";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}