$re = '/^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$/m';
$str = ' stuff before 18005551234567 stuff after';
$subst = "$1$2$3$4$5$6$7$8$9${10}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;