using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[file:(.*?(?:\.jpg|\.gif|\.bmp|\.png))(?:\||]).*";
string input = @"[[File:EDI.png|thumb|304x304px|none]]
[[File:RMS Home screen.png|thumb|none]]
[[File:ClipCapIt-170110-133309.PNG]]
[[file:send-rec.jpg|thumb|none]]
[[file:send-rec.12412.2.123.jpg|thumb|none]]
[[file:send-rec.12412.2.123.jpg|thumb|none]]
[[file:send-rec.12412.2.123.not-jpg|thumb|none]]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}