const regex = /^a\..*?\Kain't/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^a\\..*?\\Kain\'t', 'gmi')
const str = `For instance, if in the text below I wanted to replace "ain't" with "is not" for lines beginning "a." but not "b.":
a. This ain't a worm.
b. No, it ain't.
a. Ain't a snake, either.
b. No, ain't one of them.
a. ain't multiple ain't and more ain't
`;
const subst = `is not`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);