use strict;
my $str = 'For instance, if in the text below I wanted to replace "ain\'t" with "is not" for lines beginning "a." but not "b.":
a. This ain\'t a worm.
b. No, it ain\'t.
a. Ain\'t a snake, either.
b. No, ain\'t one of them.
a. ain\'t multiple ain\'t and more ain\'t
';
my $regex = qr/(?:\G(?!^)|^a\.).*?\Kain't/mip;
my $subst = 'is not';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";