import Foundation
let pattern = #"(?:\G(?!^)|^a\.).*?\Kain't"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
For instance, if in the text below I wanted to replace "ain't" with "is not" for lines beginning "a." but not "b.":
a. This ain't a worm.
b. No, it ain't.
a. Ain't a snake, either.
b. No, ain't one of them.
a. ain't multiple ain't and more ain't
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"is not"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)