$re = '/[^:,\n]+:.*?(?=,(?:\w|$))/m';
$str = 'active site: His, Glu,region: nucleotide-binding motif A,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);