using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!xxx-)(?![^@]+@test\.com$)[^@]+@[^@\n]+$";
string input = @"abc@email.com
xxx-123@domain.com
abc.123@test.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}