#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^0-9A-Za-z\n]|[a-zA-Z]+$"
Local $sString = "MA0244891-D" & @CRLF & _
" --> MA0244891" & @CRLF & _
"MA0244891" & @CRLF & _
" --> MA0244891" & @CRLF & _
"MA0244891D" & @CRLF & _
" --> MA0244891" & @CRLF & _
"0244891D" & @CRLF & _
" --> 0244891"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)