re = /(?:\(\"(.+?)\",\"(.+?)\"\)(?:, ){0,1})/
str = '("key","val"), ("key2","val\\"2"), ("key3","val3")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end