# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b's\b//gm;t' <<< "Python's Programming: is very easy to learn in str."