use strict;
my $str = 'Python\'s Programming: is very easy to learn in str.';
my $regex = qr/\b's\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";