$re = '/<look=(?\'look\'\w+)>(?\'extra\'.*)/m';
$str = '<look=Vencil>extra stuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);