use strict;
my $str = 'Hi, I am Harry Potter';
my $regex = qr/^\W*(\w+)\W+(\w+).*/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";