const regex = /(?ms)\"tag\":\s*(?<tag>[^\n]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)\\"tag\\":\\s*(?<tag>[^\\n]+)', 'gm')
const str = `"tag": AKAMAI/BOT/AKAMAI_CATEGORIZED
"tag":AKAMAI/BOT/REQUEST_ANOMALY
"tag":AKAMAI/BOT/UNKNOWN_BOT
"tag": ASE/WEB_ATTACK/CMDI
"tag": ASE/WEB_ATTACK/LFI
"tag": ASE/WEB_ATTACK/PLATFORM
"tag": ASE/WEB_ATTACK/POLICY
"tag": ASE/WEB_ATTACK/PROTOCOL
"tag": ASE/WEB_ATTACK/RFI
"tag": ASE/WEB_ATTACK/SQLI
"tag": ASE/WEB_ATTACK/WAT
"tag": ASE/WEB_ATTACK/XSS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}