using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(0?[1-9]|1\d|2[0-8])[\/](0?[1-9]|1[0-2])|(29|30)[\/](0?[13-9]|1[0-2])|(31)[\/](0?[13578]|1[02]))[\/](0{2,3}[1-9]|0{1,2}[1-9]\d|0?[1-9]\d{2}|[1-9]\d{3})|(29)[\/](0?2)[\/](\d{1,2}(?:0[48]|[2468][048]|[13579][26])|(?:0?[48]|[13579][26]|[2468][048])00))$";
string input = @"19/6/2003
23/4/2003
25/12/2022
15/7/2026
30/2/2004
32/11/2005
0/5/2001";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}