const regex = /(>=|<=|'[^']*(?:''[^']*)*')|=/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(>=|<=|\'[^\']*(?:\'\'[^\']*)*\')|=', 'g')
const str = `select * from where item1=abcd and price>=20 and item1 = abc and title='strings=evil''bugs' and id=-197`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);