import Foundation
let pattern = #"(>=|<=|'[^']*(?:''[^']*)*')|="#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"select * from where item1=abcd and price>=20 and item1 = abc and title='strings=evil''bugs' and id=-197"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)