import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([#]+|[*-+]\\.|[0-9]+\\.|[ ]{3,}|[> ]+)\\s([^\\n]+)$|([*_~\\-]+)([^\\4]+?)\\4|(`+)([^\\n]+)?\\n([^\\6]+?)\\6)";
final String string = "# 标题\n\n"
+ " 引用\n\n"
+ "> 缩进\n"
+ ">> 多级缩进\n"
+ "> > 呵呵\n\n"
+ "普通文本 *加粗文本* ***特别粗的文本*** ~删除~ _斜体_\n\n"
+ "```JavaScript\n"
+ "Code\n"
+ "```\n\n"
+ "另一个代码段\n"
+ "```\n"
+ "Code\n"
+ "```\n\n\n"
+ "## 二级标题\n\n"
+ "1. 有序 列表一\n"
+ "2. 有序列表二\n"
+ "3. 有序列表三\n\n"
+ "*. 无序列表一\n"
+ "*. 无序列表二";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}