use strict;
my $str = '# 标题
引用
> 缩进
>> 多级缩进
> > 呵呵
普通文本 *加粗文本* ***特别粗的文本*** ~删除~ _斜体_
```JavaScript
Code
```
另一个代码段
```
Code
```
## 二级标题
1. 有序 列表一
2. 有序列表二
3. 有序列表三
*. 无序列表一
*. 无序列表二';
my $regex = qr/(^([#]+|[*-+]\.|[0-9]+\.|[ ]{3,}|[> ]+)\s([^\n]+)$|([*_~\-]+)([^\4]+?)\4|(`+)([^\n]+)?\n([^\6]+?)\6)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}