import Foundation
let pattern = ##"(^([#]+|[*-+]\.|[0-9]+\.|[ ]{3,}|[> ]+)\s([^\n]+)$|([*_~\-]+)([^\4]+?)\4|(`+)([^\n]+)?\n([^\6]+?)\6)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
# 标题
引用
> 缩进
>> 多级缩进
> > 呵呵
普通文本 *加粗文本* ***特别粗的文本*** ~删除~ _斜体_
```JavaScript
Code
```
另一个代码段
```
Code
```
## 二级标题
1. 有序 列表一
2. 有序列表二
3. 有序列表三
*. 无序列表一
*. 无序列表二
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)