re = /(<\?)(.*?)(?:$|\?>)/i
str = '<?php foo(); ?>
<abc>
<? foo(); ?>
<?php
foo();
bar();
?>
foo();
bar();
<? //also short open tag
foo();
bar();
?><?php
foo();
bar();
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end