#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?>(?!\A)\G|[^<]*+<a\b(?>[^>]*?\bhref=)["'])[^"'-]*+\K-|[^>]*+>(*SKIP)(*FAIL)"
Local $sString = "<div id="breadcrumb-section">" & @CRLF & _
" <ol id="breadcrumbs">" & @CRLF & _
" <li class="first">" & @CRLF & _
" <span>" & @CRLF & _
" <a href="index.html">Technologies</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <span>" & @CRLF & _
" <a href="Some-Technologies-Documentation_218464400.html">Some Technologies Documentation</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <span>" & @CRLF & _
" <a href="Some-Other-Documentation_268370090.html">Some Other Documentation</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <span>" & @CRLF & _
" <a href="Another-Documentation_268370112.html">Another Documentation</a>" & @CRLF & _
" </span>" & @CRLF & _
" </li>" & @CRLF & _
" </ol>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")