$re = '/ (B{0,3}[^B]+)*B{0,3} | B{0,3}/m';
$str = 'sdBBdfsBBB
BfsBBBdsfBBB
fsBBBBsfBB
BBBBBfsBBBsd
BBBxBBByBBB
xBBBB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);