package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)`)
var str = `1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”
2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”
3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}