import Foundation
let pattern = #"host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”
2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”
3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)