$re = '/([\w:*=.#-\s\[\]]+(?!([^\[\{]*[\]\}@])))/';
$str = 'body {background:crimson;overflow:hidden}[id*=xat],hr,table{display:none}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);