use strict;
my $str = '{abc-def-qwe}
{anthing-else-that-you-wish}';
my $regex = qr/^\{(.+)\}$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";