const regex = /(^(([€$£]?\s*)?((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?)\s*$|(^(((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?(\s*[$€£]?)\s*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(([€$£]?\\s*)?((\\d{1,3}(\\.\\d{3})+)|\\d+))(,\\d+\\s*)?)\\s*$|(^(((\\d{1,3}(\\.\\d{3})+)|\\d+))(,\\d+\\s*)?(\\s*[$€£]?)\\s*$)', 'gm')
const str = `324242234234234234,324324234223423 €
234324fsdfsdf3424234
234.333.333,3 €
€ 234,3434234
€ 444.444
\$123.231,1222222
342342,342`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}