#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[A-Za-z0-9!#$%&'*+\-\/=?^_`{|}~]|(?<=^|\.)"|"(?=$|\.|@)|(?<=".*)[ .](?=.*")|(?<!\.)\.){1,64})(@)((?:[A-Za-z0-9.\-])*(?:[A-Za-z0-9])\.(?:[A-Za-z0-9]){2,})$"
Local $sString = "Valid email addresses" & @CRLF & _
"" & @CRLF & _
"simple@example.com" & @CRLF & _
"" & @CRLF & _
"very.common@example.com" & @CRLF & _
"" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"" & @CRLF & _
"other.email-with-hyphen@example.com" & @CRLF & _
"" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"" & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"(may go to user.name@example.com inbox depending on mail server)" & @CRLF & _
"" & @CRLF & _
"x@example.com" & @CRLF & _
"(one-letter local-part)" & @CRLF & _
"" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"" & @CRLF & _
"example@s.example" & @CRLF & _
"(see the List of Internet top-level domains)" & @CRLF & _
"" & @CRLF & _
"" "@example.org" & @CRLF & _
"(space between the quotes)" & @CRLF & _
"" & @CRLF & _
""john..doe"@example.org" & @CRLF & _
"(quoted double dot)" & @CRLF & _
"" & @CRLF & _
"=============================================================" & @CRLF & _
"Invalid email addresses" & @CRLF & _
"" & @CRLF & _
"Abc.example.com" & @CRLF & _
"(no @ character)" & @CRLF & _
"" & @CRLF & _
"A@b@c@example.com" & @CRLF & _
"(only one @ is allowed outside quotation marks)" & @CRLF & _
"" & @CRLF & _
"a"b(c)d,e:f;g<h>i[j\k]l@example.com" & @CRLF & _
"(none of the special characters in this local-part are allowed outside quotation marks)" & @CRLF & _
"" & @CRLF & _
"just"not"right@example.com" & @CRLF & _
"(quoted strings must be dot separated or the only element making up the local-part)" & @CRLF & _
"" & @CRLF & _
"this is"not\allowed@example.com" & @CRLF & _
"(spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)" & @CRLF & _
"" & @CRLF & _
"this\ still\"not\\allowed@example.com" & @CRLF & _
"(even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)" & @CRLF & _
"" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com" & @CRLF & _
"(local part is longer than 64 characters)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")