# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:[A-Za-z0-9!#$%&'*+\-\/=?^_`{|}~]|(?<=^|\.)\"|\"(?=$|\.|@)|(?<=\".*)[ .](?=.*\")|(?<!\.)\.){1,64})(@)((?:[A-Za-z0-9.\-])*(?:[A-Za-z0-9])\.(?:[A-Za-z0-9]){2,})$"
test_str = ("Valid email addresses\n\n"
"simple@example.com\n\n"
"very.common@example.com\n\n"
"disposable.style.email.with+symbol@example.com\n\n"
"other.email-with-hyphen@example.com\n\n"
"fully-qualified-domain@example.com\n\n"
"user.name+tag+sorting@example.com\n"
"(may go to user.name@example.com inbox depending on mail server)\n\n"
"x@example.com\n"
"(one-letter local-part)\n\n"
"example-indeed@strange-example.com\n\n"
"example@s.example\n"
"(see the List of Internet top-level domains)\n\n"
"\" \"@example.org\n"
"(space between the quotes)\n\n"
"\"john..doe\"@example.org\n"
"(quoted double dot)\n\n"
"=============================================================\n"
"Invalid email addresses\n\n"
"Abc.example.com\n"
"(no @ character)\n\n"
"A@b@c@example.com\n"
"(only one @ is allowed outside quotation marks)\n\n"
"a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n"
"(none of the special characters in this local-part are allowed outside quotation marks)\n\n"
"just\"not\"right@example.com\n"
"(quoted strings must be dot separated or the only element making up the local-part)\n\n"
"this is\"not\\allowed@example.com\n"
"(spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)\n\n"
"this\\ still\\\"not\\\\allowed@example.com\n"
"(even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)\n\n"
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
"(local part is longer than 64 characters)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.