import Foundation
let pattern = ##"^((?:[A-Za-z0-9!#$%&'*+\-\/=?^_`{|}~]|(?<=^|\.)"|"(?=$|\.|@)|(?<=".*)[ .](?=.*")|(?<!\.)\.){1,64})(@)((?:[A-Za-z0-9.\-])*(?:[A-Za-z0-9])\.(?:[A-Za-z0-9]){2,})$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Valid email addresses
simple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
(may go to user.name@example.com inbox depending on mail server)
x@example.com
(one-letter local-part)
example-indeed@strange-example.com
example@s.example
(see the List of Internet top-level domains)
" "@example.org
(space between the quotes)
"john..doe"@example.org
(quoted double dot)
=============================================================
Invalid email addresses
Abc.example.com
(no @ character)
A@b@c@example.com
(only one @ is allowed outside quotation marks)
a"b(c)d,e:f;g<h>i[j\k]l@example.com
(none of the special characters in this local-part are allowed outside quotation marks)
just"not"right@example.com
(quoted strings must be dot separated or the only element making up the local-part)
this is"not\allowed@example.com
(spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)
this\ still\"not\\allowed@example.com
(even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
(local part is longer than 64 characters)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)